const regex = new RegExp('(?<=\\S)[ ]{2,}(?=\\S)', 'gm')
const str = ` def post(self, request, format=None):
action = request.query_params.get('action', None)
res = 'UNKNOWN ACTION'
hhtpstatus = status.HTTP_400_BAD_REQUEST
`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);