import re
regex = re.compile(r"(?<=\S)[ ]{2,}(?=\S)", flags=re.MULTILINE)
test_str = (" def post(self, request, format=None): \n"
" action = request.query_params.get('action', None)\n"
" res = 'UNKNOWN ACTION'\n"
" hhtpstatus = status.HTTP_400_BAD_REQUEST\n\n")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)