re = /(?<=\S)[ ]{2,}(?=\S)/m
str = ' def post(self, request, format=None):
action = request.query_params.get(\'action\', None)
res = \'UNKNOWN ACTION\'
hhtpstatus = status.HTTP_400_BAD_REQUEST
'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result