import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\S)[ ]{2,}(?=\\S)";
final String string = " def post(self, request, format=None): \n"
+ " action = request.query_params.get('action', None)\n"
+ " res = 'UNKNOWN ACTION'\n"
+ " hhtpstatus = status.HTTP_400_BAD_REQUEST\n\n";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}