using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^CTC\sN\+(?:123\d{9}|(?!123)\d{10,12})\/?(EN|FR)?$";
string input = @"CTC N+6534567890/FR
CTC N+123456789012/FR
CTC N+1234567890120/FR
CTC N+1234567890/FR
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}