re = /^CTC\sN\+(?:123\d{9}|(?!123)\d{10,12})\/?(EN|FR)?$/m
str = 'CTC N+6534567890/FR
CTC N+123456789012/FR
CTC N+1234567890120/FR
CTC N+1234567890/FR
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end