import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^CTC\\sN\\+(?:123\\d{9}|(?!123)\\d{10,12})\\/?(EN|FR)?$";
final String string = "CTC N+6534567890/FR\n"
+ "CTC N+123456789012/FR\n"
+ "CTC N+1234567890120/FR\n"
+ "CTC N+1234567890/FR\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}