$re = '/^CTC\sN\+(?:123\d{9}|(?!123)\d{10,12})\/?(EN|FR)?$/m';
$str = 'CTC N+6534567890/FR
CTC N+123456789012/FR
CTC N+1234567890120/FR
CTC N+1234567890/FR
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);