import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bRecipient:\\s*(\\S+@\\S+)";
final String string = "Recipient:\n"
+ "nolo.lamb@golab.com \\--- mail_boundary --- ATTENTION: This email came from an\n"
+ "external source.\n"
+ " \n"
+ "Sender: nlrt@vloh.net Subject: [External] *LEGALZOOM OPENS AT $30, IPO\n"
+ "AT $28 Message-Id: <60DC94E60001AE8432F70080_0_2129298@mscv03>\n"
+ "Recipient: Nichole.wen@golab.com \\--- mail_boundary ---";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}