import re
regex = re.compile(r"\bRecipient:\s*(\S+@\S+)", flags=re.MULTILINE)
test_str = ("Recipient:\n"
"nolo.lamb@golab.com \\--- mail_boundary --- ATTENTION: This email came from an\n"
"external source.\n"
" \n"
"Sender: nlrt@vloh.net Subject: [External] *LEGALZOOM OPENS AT $30, IPO\n"
"AT $28 Message-Id: <60DC94E60001AE8432F70080_0_2129298@mscv03>\n"
"Recipient: Nichole.wen@golab.com \\--- mail_boundary ---")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")