import Foundation
let pattern = #"\bRecipient:\s*(\S+@\S+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Recipient:
nolo.lamb@golab.com \--- mail_boundary --- ATTENTION: This email came from an
external source.
Sender: nlrt@vloh.net Subject: [External] *LEGALZOOM OPENS AT $30, IPO
AT $28 Message-Id: <60DC94E60001AE8432F70080_0_2129298@mscv03>
Recipient: Nichole.wen@golab.com \--- mail_boundary ---
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)