// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bRecipient:\s*(\S+@\S+)").unwrap();
let string = "Recipient:
nolo.lamb@golab.com \\--- mail_boundary --- ATTENTION: This email came from an
external source.
Sender: nlrt@vloh.net Subject: [External] *LEGALZOOM OPENS AT $30, IPO
AT $28 Message-Id: <60DC94E60001AE8432F70080_0_2129298@mscv03>
Recipient: Nichole.wen@golab.com \\--- mail_boundary ---";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}