$re = '/\bRecipient:\s*(\S+@\S+)/m';
$str = 'Recipient:
nolo.lamb@golab.com \\--- mail_boundary --- ATTENTION: This email came from an
external source.
Sender: nlrt@vloh.net Subject: [External] *LEGALZOOM OPENS AT $30, IPO
AT $28 Message-Id: <60DC94E60001AE8432F70080_0_2129298@mscv03>
Recipient: Nichole.wen@golab.com \\--- mail_boundary ---';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);