#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^bamos\/openface\h+latest\h+([a-z0-9]+)"
Local $sString = "bamos/openface latest 62d1673065e8 12 weeks ago 1.941 GB" & @CRLF & _
"other/repository latest 62d1673065e8 12 weeks ago 1.941 GB" & @CRLF & _
"bamos/openface previous 62d1673065e8 12 weeks ago 1.941 GB"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")