$re = '/^bamos\/openface\h+latest\h+([a-z0-9]+)/m';
$str = 'bamos/openface latest 62d1673065e8 12 weeks ago 1.941 GB
other/repository latest 62d1673065e8 12 weeks ago 1.941 GB
bamos/openface previous 62d1673065e8 12 weeks ago 1.941 GB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);