const regex = /^bamos\/openface\h+latest\h+([a-z0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^bamos\\\/openface\\h+latest\\h+([a-z0-9]+)', 'gm')
const str = `bamos/openface latest 62d1673065e8 12 weeks ago 1.941 GB
other/repository latest 62d1673065e8 12 weeks ago 1.941 GB
bamos/openface previous 62d1673065e8 12 weeks ago 1.941 GB`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}