import re
regex = re.compile(r"^bamos\/openface\h+latest\h+([a-z0-9]+)", flags=re.MULTILINE)
test_str = ("bamos/openface latest 62d1673065e8 12 weeks ago 1.941 GB\n"
"other/repository latest 62d1673065e8 12 weeks ago 1.941 GB\n"
"bamos/openface previous 62d1673065e8 12 weeks ago 1.941 GB")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")