import Foundation
let pattern = #"^bamos\/openface\h+latest\h+([a-z0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
bamos/openface latest 62d1673065e8 12 weeks ago 1.941 GB
other/repository latest 62d1673065e8 12 weeks ago 1.941 GB
bamos/openface previous 62d1673065e8 12 weeks ago 1.941 GB
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)