using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^bamos\/openface\h+latest\h+([a-z0-9]+)";
string input = @"bamos/openface latest 62d1673065e8 12 weeks ago 1.941 GB
other/repository latest 62d1673065e8 12 weeks ago 1.941 GB
bamos/openface previous 62d1673065e8 12 weeks ago 1.941 GB";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}