import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^bamos\\/openface\\h+latest\\h+([a-z0-9]+)";
final String string = "bamos/openface latest 62d1673065e8 12 weeks ago 1.941 GB\n"
+ "other/repository latest 62d1673065e8 12 weeks ago 1.941 GB\n"
+ "bamos/openface previous 62d1673065e8 12 weeks ago 1.941 GB";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}