#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[([^<>&/\[\]\x00-\x20=]++)"
Local $sString = "This is a test [example attr1="test1" attr2="test2"]content" & @CRLF & _
"" & @CRLF & _
"over multiple" & @CRLF & _
"lines with a random [shortcode] inside[/example]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")