import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([^<>&/\\[\\]\\x00-\\x20=]++)";
final String string = "This is a test [example attr1=\"test1\" attr2=\"test2\"]content\n\n"
+ "over multiple\n"
+ "lines with a random [shortcode] inside[/example]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}