// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[([^<>&/\[\]\x00-\x20=]++)").unwrap();
let string = "This is a test [example attr1=\"test1\" attr2=\"test2\"]content
over multiple
lines with a random [shortcode] inside[/example]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}