re = /\[([^<>&\/\[\]\x00-\x20=]++)/
str = 'This is a test [example attr1="test1" attr2="test2"]content
over multiple
lines with a random [shortcode] inside[/example]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end