const regex = new RegExp('\\[([^<>&/\\[\\]\\x00-\\x20=]++)', 'g')
const str = `This is a test [example attr1="test1" attr2="test2"]content
over multiple
lines with a random [shortcode] inside[/example]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}