package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[([^<>&/\[\]\x00-\x20=]++)`)
var str = `This is a test [example attr1="test1" attr2="test2"]content
over multiple
lines with a random [shortcode] inside[/example]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}