#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^\/]+)\/(?:\1$\r?\n?)?"
Local $sString = "ABC-ABC/ABC-ABC" & @CRLF & _
"ABC-ABC/DEF-DEF" & @CRLF & _
"GHI/GHI" & @CRLF & _
"JKL/JKLM" & @CRLF & _
"A/B-C"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)