import Foundation
let pattern = #"^([^\/]+)\/(?:\1$\r?\n?)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ABC-ABC/ABC-ABC
ABC-ABC/DEF-DEF
GHI/GHI
JKL/JKLM
A/B-C
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)