re = /^([^\/]+)\/(?:\1$\r?\n?)?/m
str = 'ABC-ABC/ABC-ABC
ABC-ABC/DEF-DEF
GHI/GHI
JKL/JKLM
A/B-C'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result