$re = '/^([^\/]+)\/(?:\1$\r?\n?)?/m';
$str = 'ABC-ABC/ABC-ABC
ABC-ABC/DEF-DEF
GHI/GHI
JKL/JKLM
A/B-C';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;