const regex = /^([^\/]+)\/(?:\1$\r?\n?)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^\\\/]+)\\\/(?:\\1$\\r?\\n?)?', 'gm')
const str = `ABC-ABC/ABC-ABC
ABC-ABC/DEF-DEF
GHI/GHI
JKL/JKLM
A/B-C`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);