using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^\/]+)\/(?:\1$\r?\n?)?";
string substitution = @"";
string input = @"ABC-ABC/ABC-ABC
ABC-ABC/DEF-DEF
GHI/GHI
JKL/JKLM
A/B-C";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}