#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?<type>[a-zA-Z2]*)(\((?<precision>\d*)(,(?<scale>\d*))?\))?"
Local $sString = "varchar(30)" & @CRLF & _
"timestamp" & @CRLF & _
"number(20,5)" & @CRLF & _
"NUMBER(20,3)" & @CRLF & _
"timestamp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")