import re
regex = re.compile(r"(?<type>[a-zA-Z2]*)(\((?<precision>\d*)(,(?<scale>\d*))?\))?", flags=re.MULTILINE | re.DOTALL)
test_str = ("varchar(30)\n"
"timestamp\n"
"number(20,5)\n"
"NUMBER(20,3)\n"
"timestamp")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")