package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)(?<type>[a-zA-Z2]*)(\((?<precision>\d*)(,(?<scale>\d*))?\))?`)
var str = `varchar(30)
timestamp
number(20,5)
NUMBER(20,3)
timestamp`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}