re = /(?<type>[a-zA-Z2]*)(\((?<precision>\d*)(,(?<scale>\d*))?\))?/m
str = 'varchar(30)
timestamp
number(20,5)
NUMBER(20,3)
timestamp'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end