$re = '/(?<type>[a-zA-Z2]*)(\((?<precision>\d*)(,(?<scale>\d*))?\))?/ms';
$str = 'varchar(30)
timestamp
number(20,5)
NUMBER(20,3)
timestamp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);