package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+_build_block_\(chapter_\d+\)\.xml$`)
var str = `1_build_block_(book).xml
2_build_block_(chapter_1).xml
3_build_block_(chapter_2).xml`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}