// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+_build_block_\(chapter_\d+\)\.xml$").unwrap();
let string = "1_build_block_(book).xml
2_build_block_(chapter_1).xml
3_build_block_(chapter_2).xml";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}