use strict;
my $str = '1_build_block_(book).xml
2_build_block_(chapter_1).xml
3_build_block_(chapter_2).xml';
my $regex = qr/^\d+_build_block_\(chapter_\d+\)\.xml$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}