re = /^\d+_build_block_\(chapter_\d+\)\.xml$/m
str = '1_build_block_(book).xml
2_build_block_(chapter_1).xml
3_build_block_(chapter_2).xml'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end