$re = '/^\d+_build_block_\(chapter_\d+\)\.xml$/m';
$str = '1_build_block_(book).xml
2_build_block_(chapter_1).xml
3_build_block_(chapter_2).xml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);