#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+\/\d+\/\d+(.*?)\\n\\n(\s+\d+\/\d+\/\d+|$)"
Local $sString = "05/06/21 05/06/21 Margin Div/Int - Income ACTIVISION BLIZZARD INC\n\nCOM\nPayable: 05/06/2021\nQUALIFIED DIVIDENDS 23.50 \n\nATVI - 0.00 23.50 (9,425.77)\n\n 05/06/21 05/06/21 Margin Div/Int - Income ACTIVISION BLIZZARD INC\n\nCOM\nPayable: 05/06/2021\nQUALIFIED DIVIDENDS 23.50 \n\nATVI - 0.00 23.50 (9,000.77)\n\n 05/13/21 05/13/21 Margin Div/Int - Income APPLE INC\nCOM\nPayable: 05/13/2021\nQUALIFIED DIVIDENDS 6.16 \n\nAAPL - 0.00 6.16 (9,419.61)\n\n"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")