import Foundation
let pattern = #"\d+\/\d+\/\d+(.*?)\\n\\n(\s+\d+\/\d+\/\d+|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"05/06/21 05/06/21 Margin Div/Int - Income ACTIVISION BLIZZARD INC\n\nCOM\nPayable: 05/06/2021\nQUALIFIED DIVIDENDS 23.50 \n\nATVI - 0.00 23.50 (9,425.77)\n\n 05/06/21 05/06/21 Margin Div/Int - Income ACTIVISION BLIZZARD INC\n\nCOM\nPayable: 05/06/2021\nQUALIFIED DIVIDENDS 23.50 \n\nATVI - 0.00 23.50 (9,000.77)\n\n 05/13/21 05/13/21 Margin Div/Int - Income APPLE INC\nCOM\nPayable: 05/13/2021\nQUALIFIED DIVIDENDS 6.16 \n\nAAPL - 0.00 6.16 (9,419.61)\n\n"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)