import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\/\\d+\\/\\d+(.*?)\\\\n\\\\n(\\s+\\d+\\/\\d+\\/\\d+|$)";
final String string = "05/06/21 05/06/21 Margin Div/Int - Income ACTIVISION BLIZZARD INC\\n\\nCOM\\nPayable: 05/06/2021\\nQUALIFIED DIVIDENDS 23.50 \\n\\nATVI - 0.00 23.50 (9,425.77)\\n\\n 05/06/21 05/06/21 Margin Div/Int - Income ACTIVISION BLIZZARD INC\\n\\nCOM\\nPayable: 05/06/2021\\nQUALIFIED DIVIDENDS 23.50 \\n\\nATVI - 0.00 23.50 (9,000.77)\\n\\n 05/13/21 05/13/21 Margin Div/Int - Income APPLE INC\\nCOM\\nPayable: 05/13/2021\\nQUALIFIED DIVIDENDS 6.16 \\n\\nAAPL - 0.00 6.16 (9,419.61)\\n\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}