const regex = /\d+\/\d+\/\d+(.*?)\\n\\n(\s+\d+\/\d+\/\d+|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+\\\/\\d+\\\/\\d+(.*?)\\\\n\\\\n(\\s+\\d+\\\/\\d+\\\/\\d+|$)', 'gm')
const str = `05/06/21 05/06/21 Margin Div/Int - Income ACTIVISION BLIZZARD INC\\n\\nCOM\\nPayable: 05/06/2021\\nQUALIFIED DIVIDENDS 23.50 \\n\\nATVI - 0.00 23.50 (9,425.77)\\n\\n 05/06/21 05/06/21 Margin Div/Int - Income ACTIVISION BLIZZARD INC\\n\\nCOM\\nPayable: 05/06/2021\\nQUALIFIED DIVIDENDS 23.50 \\n\\nATVI - 0.00 23.50 (9,000.77)\\n\\n 05/13/21 05/13/21 Margin Div/Int - Income APPLE INC\\nCOM\\nPayable: 05/13/2021\\nQUALIFIED DIVIDENDS 6.16 \\n\\nAAPL - 0.00 6.16 (9,419.61)\\n\\n`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}