use strict;
my $str = '05/06/21 05/06/21 Margin Div/Int - Income ACTIVISION BLIZZARD INC\\n\\nCOM\\nPayable: 05/06/2021\\nQUALIFIED DIVIDENDS 23.50 \\n\\nATVI - 0.00 23.50 (9,425.77)\\n\\n 05/06/21 05/06/21 Margin Div/Int - Income ACTIVISION BLIZZARD INC\\n\\nCOM\\nPayable: 05/06/2021\\nQUALIFIED DIVIDENDS 23.50 \\n\\nATVI - 0.00 23.50 (9,000.77)\\n\\n 05/13/21 05/13/21 Margin Div/Int - Income APPLE INC\\nCOM\\nPayable: 05/13/2021\\nQUALIFIED DIVIDENDS 6.16 \\n\\nAAPL - 0.00 6.16 (9,419.61)\\n\\n';
my $regex = qr/\d+\/\d+\/\d+(.*?)\\n\\n(\s+\d+\/\d+\/\d+|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}