// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+\/\d+\/\d+(.*?)\\n\\n(\s+\d+\/\d+\/\d+|$)").unwrap();
let string = "05/06/21 05/06/21 Margin Div/Int - Income ACTIVISION BLIZZARD INC\\n\\nCOM\\nPayable: 05/06/2021\\nQUALIFIED DIVIDENDS 23.50 \\n\\nATVI - 0.00 23.50 (9,425.77)\\n\\n 05/06/21 05/06/21 Margin Div/Int - Income ACTIVISION BLIZZARD INC\\n\\nCOM\\nPayable: 05/06/2021\\nQUALIFIED DIVIDENDS 23.50 \\n\\nATVI - 0.00 23.50 (9,000.77)\\n\\n 05/13/21 05/13/21 Margin Div/Int - Income APPLE INC\\nCOM\\nPayable: 05/13/2021\\nQUALIFIED DIVIDENDS 6.16 \\n\\nAAPL - 0.00 6.16 (9,419.61)\\n\\n";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}