using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+\/\d+\/\d+(.*?)\\n\\n(\s+\d+\/\d+\/\d+|$)";
string input = @"05/06/21 05/06/21 Margin Div/Int - Income ACTIVISION BLIZZARD INC\n\nCOM\nPayable: 05/06/2021\nQUALIFIED DIVIDENDS 23.50 \n\nATVI - 0.00 23.50 (9,425.77)\n\n 05/06/21 05/06/21 Margin Div/Int - Income ACTIVISION BLIZZARD INC\n\nCOM\nPayable: 05/06/2021\nQUALIFIED DIVIDENDS 23.50 \n\nATVI - 0.00 23.50 (9,000.77)\n\n 05/13/21 05/13/21 Margin Div/Int - Income APPLE INC\nCOM\nPayable: 05/13/2021\nQUALIFIED DIVIDENDS 6.16 \n\nAAPL - 0.00 6.16 (9,419.61)\n\n";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}