# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*(\\/\\/damn.at)\\/(.*)(\?go-get=)(.*)/https:\/\/go.damn.at\/go.php?pkg=$2&get=1/gm;t' <<< "https://damn.at/tests?go-get=1
https://damn.at/dd?go-get=1
https://damn.at/fuck/more/shit?go-get=1"